Search/CVE-2026-33642
● CVE — Critical

CVE-2026-33642

VendorkovidgoyalProductkittyDiscoveredMay 19, 2026UpdatedJul 24, 2026

Kitty is a cross-platform GPU based terminal. In versions 0.46.2 and below, the handle_compose_command() function in kitty/graphics.c performs bounds validation on composition offsets using unsigned 32-bit arithmetic that is subject to integer wrapping, potentially leading to Heap Buffer Over-Read/Write. An attacker who can write escape sequences to a kitty terminal (e.g., via a malicious file, SSH login banner, or piped content) can supply crafted x_offset/y_offset values that pass the bounds check after wrapping but cause massive out-of-bounds heap memory access in compose_rectangles(). No user interaction is required. No non-default configuration is required. The attacker only needs the ability to produce output in a kitty terminal window. This issue has been fixed in version 0.47.0.

CVSS v3.1
9.9 CRITICAL
EPSS
0.29%
probability of exploitation in 30 days
CISA KEV
Not listed
no confirmed exploitation reported
News coverage
1
sources referencing this CVE
Related IOCs
0
seen in the same coverage
EPSS Trend
Aug 16, 2026 → Oct 26, 2026
● 0.00pp
0.29% → 0.29% over 3 tracked changes
CVSS v3.1 Detail
Attack VectorNETWORK
Attack ComplexityLOW
Privileges RequiredNONE
User InteractionNONE
ScopeCHANGED
ConfidentialityLOW
IntegrityLOW
AvailabilityHIGH
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:H
Connections
3 relationships
Timeline
disclosure → media coverage
May 19, 2026
Disclosure — published as a CVE record. · last revised by NVD Jul 24, 2026
Jun 17, 2026
ubuntu.com reports: USN-8442-1: kitty vulnerabilities