Search/CVE-2026-33633
● CVE — High

CVE-2026-33633

VendorkovidgoyalProductkittyDiscoveredMay 19, 2026UpdatedJul 24, 2026

Kitty is a cross-platform GPU based terminal. Versions 0.46.2 and below contain a heap buffer overflow in load_image_data() that allows any process which can write to the terminal's stdin to crash kitty immediately. The vulnerability is triggered by a single APC graphics protocol command with a PNG format declaration (f=100) whose payload exceeds twice the initial buffer capacity. The overflow is attacker-controlled in both length and content, causing DoS and potentially escalation to RCE itself. This issue has been fixed in version 0.47.0.

CVSS v3.1
7.5 HIGH
EPSS
0.38%
probability of exploitation in 30 days
CISA KEV
Not listed
no confirmed exploitation reported
News coverage
1
sources referencing this CVE
Related IOCs
0
seen in the same coverage
EPSS Trend
Aug 16, 2026 → Oct 26, 2026
● 0.01pp
0.37% → 0.38% over 4 tracked changes
CVSS v3.1 Detail
Attack VectorNETWORK
Attack ComplexityHIGH
Privileges RequiredNONE
User InteractionREQUIRED
ScopeUNCHANGED
ConfidentialityHIGH
IntegrityHIGH
AvailabilityHIGH
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H
Connections
3 relationships
Timeline
disclosure → media coverage
May 19, 2026
Disclosure — published as a CVE record. · last revised by NVD Jul 24, 2026
Jun 17, 2026
ubuntu.com reports: USN-8442-1: kitty vulnerabilities