Search/CVE-2026-28780
● CVE — Critical

CVE-2026-28780

VendorapacheProducthttp serverDiscoveredMay 5, 2026UpdatedSep 14, 2026

Heap-based Buffer Overflow vulnerability in mod_proxy_ajp of Apache HTTP Server. If mod_proxy_ajp connects to a malicious AJP server this AJP server can send a malicious AJP message back to mod_proxy_ajp and cause it to write 4 attacker controlled bytes after the end of a heap based buffer. This issue affects Apache HTTP Server: through 2.4.66. Users are recommended to upgrade to version 2.4.67, which fixes the issue.

CVSS v3.1
9.8 CRITICAL
EPSS
1.38%
probability of exploitation in 30 days
CISA KEV
Not listed
no confirmed exploitation reported
News coverage
1
sources referencing this CVE
Related IOCs
0
seen in the same coverage
EPSS Trend
Aug 16, 2026 → Oct 26, 2026
● 0.00pp
1.38% → 1.38% over 3 tracked changes
CVSS v3.1 Detail
Attack VectorNETWORK
Attack ComplexityLOW
Privileges RequiredNONE
User InteractionNONE
ScopeUNCHANGED
ConfidentialityHIGH
IntegrityHIGH
AvailabilityHIGH
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Connections
4 relationships
Timeline
disclosure → media coverage
May 5, 2026
Disclosure — published as a CVE record. · last revised by NVD Sep 14, 2026
May 6, 2026
ubuntu.com reports: USN-8239-1: Apache HTTP Server vulnerabilities