Search/CVE-2026-27820
● CVE — Critical

CVE-2026-27820

Vendorruby-langProductzlibDiscoveredApr 16, 2026UpdatedOct 26, 2026

zlib is a Ruby interface for the zlib compression/decompression library. Versions 3.0.0 and below, 3.1.0, 3.1.1, 3.2.0 and 3.2.1 contain a buffer overflow vulnerability in the Zlib::GzipReader. The zstream_buffer_ungets function prepends caller-provided bytes ahead of previously produced output but fails to guarantee the backing Ruby string has enough capacity before the memmove shifts the existing data. This can lead to memory corruption when the buffer length exceeds capacity. This issue has been fixed in versions 3.0.1, 3.1.2 and 3.2.3.

CVSS v3.1
9.8 CRITICAL
EPSS
0.56%
probability of exploitation in 30 days
CISA KEV
Not listed
no confirmed exploitation reported
News coverage
1
sources referencing this CVE
Related IOCs
0
seen in the same coverage
EPSS Trend
Aug 16, 2026 → Oct 26, 2026
● 0.00pp
0.56% → 0.56% over 3 tracked changes
CVSS v3.1 Detail
Attack VectorNETWORK
Attack ComplexityLOW
Privileges RequiredNONE
User InteractionNONE
ScopeUNCHANGED
ConfidentialityHIGH
IntegrityHIGH
AvailabilityHIGH
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Connections
4 relationships
Timeline
disclosure → media coverage
Apr 16, 2026
Disclosure — published as a CVE record. · last revised by NVD Oct 26, 2026
Jul 16, 2026
ubuntu.com reports: USN-8556-1: Ruby vulnerabilities