Search/CVE-2026-121652
● CVE — Medium

CVE-2026-121652

DiscoveredNov 3, 2026UpdatedNov 3, 2026

Cross-site scripting (XSS) issue in AWS Amplify maplibre-gl-js-amplify before 4.0.3 might allow remote authenticated users to inject arbitrary web script or HTML via the (1) title, (2) address, or (3) place_name property in GeoJSON feature data rendered by popupRender, or the (4) geofenceId value rendered in AmplifyGeofenceControl. To remediate this issue, users should upgrade to 4.0.3 or later.

CVSS v3.1
5.4 MEDIUM
EPSS
—%
probability of exploitation in 30 days
CISA KEV
Not listed
no confirmed exploitation reported
News coverage
1
sources referencing this CVE
Related IOCs
0
seen in the same coverage
CVSS v3.1 Detail
Attack VectorNETWORK
Attack ComplexityLOW
Privileges RequiredLOW
User InteractionREQUIRED
ScopeCHANGED
ConfidentialityLOW
IntegrityLOW
AvailabilityNONE
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Connections
2 relationships
Timeline
disclosure → media coverage
Nov 3, 2026
aws.amazon.com reports: CVE-2026-121652 - Stored cross-site scripting (XSS) in AWS Amplify maplibre-gl-js-amplify popup rendering
Nov 3, 2026
Disclosure — published as a CVE record.